سؤال كيف يمكنني الحصول على qmake على نظام التشغيل Mac OS X؟


أحاول تثبيت QtiPlot على نظام التشغيل Mac OS X ، ولكن لا يمكنني تجميعه بما أن qmake غير معروف. كيف يمكنني تثبيت qmake على نظام التشغيل Mac OS X؟


74
2018-03-11 12:37


الأصل




الأجوبة:


البيرة الإصدار

$ brew install qt

113
2018-05-10 09:22



أفضل من MacPorts! - Fábio Perez
إذا حصلت Error: Qt currently requires --HEAD on Mavericks، يركض brew install qt --HEAD (يتطلب git). - Jace Browning
في حين qmake موجود في حزمة Homebrew ، ولا يبدو أنه تم ترميزه بشكل افتراضي بعد الآن. محاولة brew link qt    أو إذا لم يفلح ذلك: ln -s /usr/local/Cellar/qt/<QT_VERSION_HERE>/bin/qmake /usr/local/bin/qmake - TrinitronX
إذا كنت بحاجة إلى إصدار محدد من qt، فمثلا 4.8.7_2: استعمال brew switch qt 4.8.7_2. تأكد من إضافته إلى PATH: export PATH="/usr/local/opt/qt/bin:$PATH" - TrinitronX
لقد قمت بتثبيت qt مع Homebrew لكن لم أجد أداة صيانة Qt - user36582


لقد حصلت عليه للتو!

  1. تثبيت MacPorts: http://www.macports.org/

  2. على المحطة: sudo port install qt4-mac 

ثم حصلت على qmake. يمكنك تثبيت qtiplot مباشرة عن طريق تشغيل: sudo port install qtiplot. تستغرق العملية حوالي 3 ساعات.


20
2018-03-20 18:18



يبدو أنه إما تحديث المسار أو ترميزًا يدويًا qmake مطلوب الآن: stackoverflow.com/a/31318672/1959808 - Ioannis Filippidis


فقط للتوضيح لأي شخص يجد أنه بعد تثبيت qt5 ، لا يمكن الوصول إليه كماكي في المحطة.

قم بتثبيت QT5 باستخدام:

brew install qt5

ثم السماح بالوصول كماكي من الجهاز ستحتاج إلى تشغيل:

brew link qt5 --force

16
2017-12-06 00:54





يتوفر برنامج Qt المثبت الرسمي ، بما في ذلك qmake ، من نوكيا على http://qt.nokia.com/downloads، لكن كن حريص:

ما يسمى تنزيل "SDK" ، الذي يظهر بالقرب من أعلى الصفحة ليس ماتريد. بشكل مثير ، تتوفر qmake والأدوات الأخرى المطلوبة من تنزيل "مكتبات Qt". قم بالتمرير لأسفل الصفحة وابحث عن "مكتبات Qt". هذا يجعلني مرتبكًا في كل مرة أقوم فيها بتثبيت Qt على نظام Mac.


13
2017-09-29 18:44





QMake جزء من Qt منذ الإصدار 3.0 ، كانت الإصدارات السابقة tMake.

لذلك ، إما البحث عن tMake بدلا من ذلك أو تثبيت / ترقية الخاص بك Qt للحصول على QMake، حظا سعيدا!


8
2018-03-11 12:42



ليس لدي Qt مثبت. أريد فقط تثبيت QtiPlot ، لكن وثائقها ليست بديهية. - Fábio Perez
سوف تحتاج إلى Qt-devel و Qt-config واعتماديتهم من أجل الحصول عليها QMake - Tom Wijsman
شكرا ، هل تعرف أي بديل ل qmake؟ - Fábio Perez
@ FábioPerez: لا ، مكتوب QtiPlot مع القصد أن QMake يولد Makefiles. - Tom Wijsman


لتثبيت Qt5 مع الشراب ، يمكنك القيام به

الشراب تركيب qt5


5
2017-11-16 03:05



أليس هذا في الأساس نفس الإجابة المقبولة (أليس من شأن أي شخص يقوم بعملية التثبيت أن يتعرف على تغيير الاسم ويفهم كيفية استخدام الاسم الفعلي لما يريد تثبيته)؟ - fixer1234
هذا أعطاني qt5 لكن ليس qmake. أنا فقط احصل على qmake مع brew install qt، ولكن بعد ذلك هو الإصدار القديم من qmake :( - Thomas Ahle
عملت لي من خلال القيام بما اقترحه elMarquis - Riccardo Cossu
لا يمكن معرفة ما إذا كان مرادفا في البيرة ، لكنه يفعل نفس الشيء brew install qt. اليوم وصفة البيرة لا ترتبط qtmake للأسف. - paul_h
هذا يشمل على الاطلاق qmake. انظر جواب elMarquis. - Flimbus Akimbo