سؤال كيف يمكنني الحصول على دعم جافا على Google Chrome في Linux؟


هل هناك طريقة لتشغيل Linux Google Chrome مع دعم جافا؟


85


الأصل


ملاحظة المنسق: أزلت الإجابات التي أصبحت قديمة الآن ، نظرًا لأن Chrome 35 انخفض دعم NPAPI والطرق المنشورة هنا كل شيء لا يعمل. لا نزيل عادةً الأجوبة القديمة في حالة ما إذا كان الأشخاص لا يزالون يريدون تشغيل إصدارات قديمة ثابتة من البرامج ، ولكن مع Chrome ، فهذا ليس عمليًا أو عمليًا حقًا. نتطلع إلى الحصول على إجابات تفكر في الإصدار الأحدث ، وبالتالي جعل ويكي المجتمع هذا يشجع على بذل جهود مشتركة. - slhck
سؤال متعلق بسؤال أوبونتو: askubuntu.com/questions/470594/... - slhck
افايك وايضا حسب productforums.google.com/forum/#!topic/chrome/qPiZkcLwFFk لا توجد طريقة لدعم جافا في إصدارات Google Chrome for Linux الحديثة. لذا انتقل إلى Firefox أو استخدم - حريصًا - إصدارًا قديمًا من Chrome. - lmedinas
المعلومات على java.com/en/download/faq/chrome.xml مشوشة بعض الشيء ، ولكن يبدو أن هناك حاجة إلى استخدام Chrome 64 بت و 64 بت Java 7 لتشغيل جافا في Linux. (يدعي أن Chrome ليس لديه إصدار Linux من نوع 64 بت ، ولكن هذا خطا). - trlkly
شيء آخر لم أختبره ، لذا لن استخدمه كإجابة: ماذا يحدث إذا قمت بتشغيل Chrome في Wine؟ هل يعمل مكون Windows 7 Java الإضافي؟ إذا كان الأمر كذلك ، فهناك مشروعات للحصول على مكونات إضافية تعمل في Windows للتشغيل في متصفحات Linux. واحد يستخدم للحصول على عمل Netflix ، على سبيل المثال. (هذا هو أساسا اقتراح لمساعدة الناس في العثور على إجابة). - trlkly


الأجوبة:


هناك رجل (مايكل مولر) الذي كتب بعض التصحيحات لإعادة تمكين دعم NPAPI (لذلك سوف يعمل icedtea).

هذا إلى حد ما حل. ولكن من المتوقع أن تعمل. (في الواقع لم أختبره)

حاليا إصدار البناء هو 36.

إذا كنت تستخدم ArchLinux ، فيمكنك بناءه وتثبيته من AUR. الكروم وNPAPI

إن لم يكن ، يمكنك أن ترى في PKGBUILD عملية البناء.


1





حاول تثبيت icedtea في لينكس. أنه يعمل مثل السحر.

لأوبونتو

apt-get install icedtea


-3



هل يعمل هذا بالفعل على Chrome 35 أو الأحدث؟ - Journeyman Geek♦
هذا لا يعمل. المرجع: superuser.com/questions/44827/... - Sathya♦