سؤال مخارج tmux مع [خرج] على نظام التشغيل Mac OS x


أنا فقط ركبت tmux (معدد محطة) مع البيرة. عندما أحاول تشغيله ، فإنه يخرج دائمًا [exited] لا شيء يظهر.

عندما أحاول الركض tmux list-session أحصل على خطأ:

فشل في الاتصال بالخادم: تم رفض الاتصال

حاولت الركض tmux start-serverولكن مرة أخرى لا يحدث شيء.

ماذا بإمكاني أن أفعل؟


82
2018-03-05 13:50


الأصل


البدء في استخدام الخيار -v لزيادة الإسهاب - Florenz Kley
افحص default-command و default-shell خيارات. إذا tmux تواجه مشكلة في تشغيل الأمر الافتراضي (أو shell) سوف يستجيب كما تصف. لمزيد من التحقيق ، يمكنك استخدام فعل شيء من هذا القبيل tmux new /bin/zsh للبدء صراحةً (على سبيل المثال) /bin/zsh بدلا من الاعتماد عليها default-command أو default-shell. - Chris Johnsen
tmux new /bin/zsh عملت بالنسبة لي. شكرا لكم. - Stevens
إيه ، كان يقصد اقتراحي كخطوة التشخيص ، وليس حلا نهائيا. ربما هناك شيء عربات التي تجرها الدواب حول الخاص بك default-shell أو default-command ضبط. - Chris Johnsen
لقد وجدت مؤخرًا (لأول مرة) أنه إذا كان 1) .tmux.conf موجودًا ولكن يحتوي على أخطاء في بناء الجملة أو 2) .tmux.conf هو ارتباط رمزي لا يرتبط بأي شيء ، فلن يتم فتح tmux. قد يكون من الجيد أن تجرب أولاً باستخدام ملف التكوين الافتراضي أولاً mv $HOME/.tmux.conf $HOME/.tmux.conf.backup ومعرفة ما إذا كان tmux يبدأ. ChrisJohnsen على حق ، الحل الخاص بك يعني ببساطة أن هناك خلل على قدم وساق. - scicalculator


الأجوبة:


كان عندي نفس هذه المشكلة. كان سببه وجود set-option -g default-command "reattach-to-user-namespace -l zsh" في .tmux.conf بدون امتلاك ، أعد للمستخدم مساحة الاسم المثبتة.

كان الإصلاح لتثبيت "reattach-to-user-namespace" عبر Homebrew (brew install reattach-to-user-namespace)


172
2017-07-28 20:04



رائع شكرا! بالضبط ما كان في عداد المفقودين على نظام بلدي لجعله يعمل! - DannyRe
+1 شكرا للطن! كان عندي نفس المشكلة بالضبط. هل تعرف أي طريقة لتعيين الخيارات بشروط بحيث لن تفشل في نظام لا يملك reattach-to-user-namespace المثبتة؟ - Patrick Oscity
padde انظر هذا الحل. - jrhorn424
أي فكرة عن كيفية تحقيق ذلك في أوبونتو؟ حاول البحث عن طريقة للتنزيل reattach-to-user-namespace لكن جهودي كانت غير مجدية. - DaMainBoss
DaMainBoss reattach-to-user-namespace هو ل tmux فقط. إذا كنت على ubuntu فقط قم بالتعليق على هذا السطر من ملف tmux.conf الخاص بك - pho79


تأكد من أن الافتراضي قذيفة يحتوي الخيار فقط على المسار القابل للتنفيذ ولا يحتوي على خيارات.

في /etc/tmux.conf أو ~/.tmux.conf

set-option -g default-shell "/ bin / bash"
set-option -g default-command "bash -l"
set-option -g default-path $ HOME
set-option -g default-terminal "screen-256color"

6
2017-10-17 04:58



أدت هذه الإجابة لي إلى السبب الحقيقي ، كنت قد قمت فقط بإلغاء تثبيت tcsh ، وكان لا يزال يتم تعيين شل الافتراضي والأمر الافتراضي إلى ذلك. تغييره إلى / bin / ksh ، أو غلاف افتراضي مثبت من اختيارك ، ثبته لي. - Jason Robinson


إذا كنت تستخدم برنامجًا نصيًا للتغليف reattach-to-user-namespace، كما هو محدد من قبل jimeh، لا تنس أن تجعل البرنامج النصي قابل للتنفيذ chmod +x ~/bin/login-shell.


0
2017-10-10 22:37